Lunarpages Web Hosting Forum

Author Topic: plupload - 403 Forbidden  (Read 13746 times)

Offline wushu22

  • Newbie
  • *
  • Posts: 2
plupload - 403 Forbidden
« on: July 17, 2017, 01:13:30 AM »
Hi All,

We're having an issue with "403 Forbidden" error while trying to upload big files(10-20Mb) split into chunks of 1-2Mb using plupload library.

This thing was tested on our dev server and everything was working OK.

On lunarpages we met this weird issue.
When we start upload process - several equal size chunks are uploaded one by one without any issues (this is just a loop sending ajax requests to the server)
Then suddenly when we attempt to send another chunk we receive response from server:

<title>403 Forbidden</title>
<p>You don't have permission to access /path_to_script/upload.php
on this server.</p>
<address>Apache/2.2.3 (CentOS) Server at Port 80</address>

Sometimes we can upload 2 of 5 chunks
Sometimes for ex.: 6 of 17 chunks..

We know that this is not an issue with server settings like post_max_size or php run time limit.

Thanks in advance if anyone can advice the reason of this behaviour.


Offline wushu22

  • Newbie
  • *
  • Posts: 2
Re: plupload - 403 Forbidden
« Reply #1 on: July 17, 2017, 01:36:51 AM »

I have attached an image to illustrate how this looks like.

Offline MrPhil

  • Senior Moderator
  • Berserker Poster
  • *****
  • Posts: 6429
Re: plupload - 403 Forbidden
« Reply #2 on: July 17, 2017, 07:28:16 AM »
Well, that's a strange one. A few thoughts:
  • Are you sure you're letting the upload operation complete before starting the next one? If you tried to have several uploads going at once, that might cause problems (although a 403 error is a bit confusing). Try putting a one or two second pause between uploads and see if that helps.
  • Have you checked that all the chunks have the same (readable) permissions? They are all correctly named? The message hinted that it couldn't find the file you were trying to upload, rather than the utility to do the upload.
  • A 20 MB file isn't that large. Have you tried just uploading it in one try, rather than splitting it into chunks? It might be worth splitting up if you have an unreliable connection and don't want to have to start a full sized upload multiple times.
If none of these help, I would open a support ticket with Lunarpages to see what they can find. Since it's not consistently failing on the first upload attempt, it sounds like your path and executable file permissions are OK.
« Last Edit: July 17, 2017, 07:30:06 AM by MrPhil »
Visit My Site

E-mail Me
-= From the ashes shall rise a sooty tern =-