Lunarpages Web Hosting Forum

Author Topic: "Can't get remote folder info"  (Read 2655 times)

Offline morbro2.com

  • Space Explorer
  • ***
  • Posts: 8
    • http://morbrook.com
"Can't get remote folder info"
« on: October 03, 2003, 07:48:16 PM »
Not only am I a newbie, but I'm not feeling very smart.

So far I cannot figure out why my page revisions at the local level do not automatically update at the remote level.  I am using Dreamweaver MX 1992.  In the Site Definition Menu/Remote Folder, I have checked "Automatically upload files to server on save."  The [non] execution of this command is at the source of my problem;  the issue appears to be one of [non] handshaking.

Here's the sequence:  after making my changes in DW at the local level and issuing the save command, eros tries to update that file on my [remote] website;  failing this, it comes back with with this error message: "An FTP error occurred; cannot get remote folder."

Thinking the problem was at the local level, I thoroughly checked out my Site Definition Menu : the remote host tests successfully in the REMOTE INFO menu:  "Dreamweaver connected to your web server successfully."  Ditto for running the same test in the TESTING SERVER menu.  Obviously, the problem cannot be at this level.

After checking and re-checking my settings and all, I don't know where else to look.  Could the problem be with my site root URL?  HTTP://.eros.lunarpages.com~morbro2/public_html.  [I've tried variations of this to no avail.]

So I turn to you, kind reader, for enlightenment.  What am I doing wrong?  Thanks.  David
edam

stephan

  • Guest
"Can't get remote folder info"
« Reply #1 on: October 04, 2003, 05:06:40 AM »
Hello,

Make sure that you don't put "public_html" on the end.

That is where you put your files, but

http://eros.lunarpages.com/~morbro2/ will point to the files inside that directory anyway.

In the link you posted, there was a . in the wrong place, and it was missing a /


http://eros.lunarpages.com/~morbro2/ should work fine :-)

By the way, if you rename your _index.html file to index.html (in lowercase), it will be the default page when someone visits
http://eros.lunarpages.com/~morbro2/

I hope that helps.

Offline morbro2.com

  • Space Explorer
  • ***
  • Posts: 8
    • http://morbrook.com
Thanks, Stephan, but . . .
« Reply #2 on: October 04, 2003, 02:06:49 PM »
I REALLY appreciate your prompt response and ideas.  I have tried them . . . alas to no avail.  The root problem perhaps is different from how I perceive and describe it, and/or . . .

For the time being, I have devised a work-around to synching the automatic updating of the local site to the remote site, until such time as I have the smarts to tackle it again.

Meanwhile, a new bug has arised with the LINKAGES of my site . . . cf.new post under 'Beginner' in about 10-15 minutes.

Again, THANKS.  Last night I perused all the archived 'Beginner' files back to May 2002, and was VERY impressed by the quantity and quality of your feedback, Stephan.  Thanks for all you do for all of us.  edam
edam

stephan

  • Guest
"Can't get remote folder info"
« Reply #3 on: October 05, 2003, 03:43:59 AM »
Thanks :-)

I'll take a look at your other post now.

Offline TWebMan

  • Quantum Encyclopedia Writer
  • *****
  • Posts: 3047
    • Take charge of your site
"Can't get remote folder info"
« Reply #4 on: October 05, 2003, 04:16:22 AM »
You want to put /public_html/ in as the remote folder, and set PASV mode in the remote settings for that site in Dreamweaver.

Take a look at http://twebman.lunarpages.com/mm/dw/ as it may help.  Start with the first link there.
"Computers cause people to make more mistakes than any other invention in history, with the possible exception of handguns and tequila."  - Unknown
"Liberty of any kind is seldom lost all at once." - D. Hume
Every day is an Ode to Joy
The planet will be fine... and so will your site

Offline morbro2.com

  • Space Explorer
  • ***
  • Posts: 8
    • http://morbrook.com
"Can't get remote folder info"
« Reply #5 on: October 05, 2003, 04:19:07 PM »
OOPS!

You HAVE been BUSY.  

I saw your latest post here just a moment ago when responding to your previous post on the 'tab' matter.

Sorry for missing it earlier.  

I'll get back to it as soon as I finish taking your previous advice concerning eliminating uppercase letter and word spacing from my file names and directories.  I have a ways to go . . . but will get back to you in due course.

Again, I cannot thank you enough, Stephan.
edam