Lunarpages Web Hosting Forum

Author Topic: Tabbed navbar isn't 'tabbing'  (Read 693 times)

Offline morbro2.com

  • Space Explorer
  • ***
  • Posts: 8
    • http://morbrook.com
Tabbed navbar isn't 'tabbing'
« on: October 04, 2003, 02:21:43 PM »
My website design is a knock-off of something I liked from Mike Hall of [Brainjar.com.]  The difference being, his works, mine doesn't.

If you visit my new site at www.morbrook.com, you'll see what I mean.  As one moves through the tabs, the response indicates the appropriate 'sitefile' cannot be located . . . EXCEPT for the "Morbrook Only" tab and the "Home" tab.

Why this happens I would like to know.  When tested at local site-level, the tabs and links work perfectly [i.e. when I ask Dreamweaver to preview the files in this or that browser.] There's no hint of a problem until the files are uploaded to lunarpages and run through the various browsers.

I'm stumped.  Except for the usual XHTML differences, the site validates.  I have examined and re-examined the code line by line and letter by letter for discrepancies and inconsistencies, to no avail.  For example, there's no perceivable difference [to MY eyes] in the code for the "Morbrook Only" tab as compared to the others;  yet, MO WORKS and the others don't.  Help [please]![/url]
edam

stephan

  • Guest
Tabbed navbar isn't 'tabbing'
« Reply #1 on: October 05, 2003, 03:47:24 AM »
The problem is caused by the filenames and directory names you have chosen.

On unix/linux, files are case sensitive. Upper and Lower case letters are not the same.

Also, it is often a good idea to avoid using spaces.


For example, this file:

http://www.morbrook.com/1.WHO WE ARE/_sitemap1.html

You need to take out the spaces, and replace them with underscores. This is not essential, but it's a good idea.

Also, it's easier just to use lower case for all your html, directory names and filenames.

Once you have made those changes, there will be no problem.

Offline morbro2.com

  • Space Explorer
  • ***
  • Posts: 8
    • http://morbrook.com
Tabbed navbar isn't 'tabbing'
« Reply #2 on: October 05, 2003, 10:13:51 AM »
Sounds good to me. I'll try it and let you know.  Wish there were some magical way I could instantly 'know' all these nitty-gritty things so as to same your valued time for more critical issues. Thanks again.
edam

Offline morbro2.com

  • Space Explorer
  • ***
  • Posts: 8
    • http://morbrook.com
Tabbed navbar isn't 'tabbing'
« Reply #3 on: October 05, 2003, 04:12:49 PM »
:D
WELL BLOW ME DOWN!  It WORKED!

As you suggested, I started going through my files and directories, eliminating uppercase lettering, eliminating spaces between words.  Those files and directives for which I have done so test out beautifully.  Thanks not only for helping me with this website, but more importantly, for helping me become a better web designer.

Thank you.  Thank you.  Thank you. Stephan!  Bravo for a well-done.
 :P
edam