Lunarpages Web Hosting Forum

Author Topic: tfmail error message  (Read 20514 times)

Offline dgonline

  • Newbie
  • *
  • Posts: 4
tfmail error message
« on: January 29, 2011, 12:21:00 PM »
Hi, this is new to me.  Everything was fine when I was with *another webhost* and I moved to *another webhost* and am having problems with the configuration.

I keep getting a error message: when accessing http://dgagnon.net/cgi-bin/dana.pl through form submission.  This shows me that I am not accessing the file.

Then when I access the file I get: Application Error - An error has occurred in the program ~~~~~~~~ I don't know why.  I STILL RECEIVE THE EMAILS OF THE SUBMITTED FORM, JUST THE REDIRECT IS NOT WORKING.

1- I don't have a public_html folder, all files are stored on root..... can't understand when to use (home/users/web/b2625/ipg.log_in_name) which is my user root.  I can only access the root folder / so this is where my cgi-bin and tfmail folder are stored.

My cgi- error log has shown me this (which I can't understand)

20110129T150755: dgagnon.net/cgi-bin/dana.pl
Can't locate NMStreq.pm in @INC (@INC contains: /home/LOG_IN_NAME/tfmail/lib/ /usr/local/lib/perl5/5.8.8/i686-linux /usr/local/lib/perl5/5.8.8 /usr/local/lib/perl5/site_perl/5.8.8/i686-linux /usr/local/lib/perl5/site_perl/5.8.8 /usr/local/lib/perl5/site_perl /usr/local/lib/perl/5.8.4 /usr/local/lib/site_perl) at /home/users/web/b2625/ipg.LOG_IN_NAME/cgi-bin/dana.pl line 53.
BEGIN failed--compilation aborted at /home/users/web/b2625/ipg.LOG_IN_NAME/cgi-bin/dana.pl line 53.
 
20110129T151044: dgagnon.net/cgi-bin/dana.pl
bad logfile name [
] at /home/users/web/b2625/ipg.LOG_IN_NAME/cgi-bin/dana.pl line 1048


use constant DEBUGGING      => 0;
use constant LIBDIR         => '/home/users/web/b2625/ipg.LOG_IN_NAME/tfmail/lib/';
use constant MAILPROG       => '/usr/sbin/sendmail -oi -t';
use constant POSTMASTER     => 'dana@dgagnon.net';
use constant CONFIG_ROOT    => '/home/users/web/b2625/ipg.LOG_IN_NAME/tfmail/cfg/';
use constant SESSION_DIR    => '.';
use constant MAX_DEPTH      => 0;
use constant CONFIG_EXT     => '.trc';
use constant TEMPLATE_EXT   => '.trt';
use constant ENABLE_UPLOADS => 1;
use constant USE_MIME_LITE  => 1;
use constant LOGFILE_ROOT   => '/home/users/web/b2625/ipg.LOG_IN_NAME/tfmail/log/';
use constant LOGFILE_EXT    => '.log';
use constant HTMLFILE_ROOT  => '';
use constant HTMLFILE_EXT   => '.html';
use constant CHARSET        => 'iso-8859-1';

So I am missign somethign and I am not sure what.  Like I said it worked fine at *another webhost* and I have tried so many configurations.  the "application error" is as close as it comes.  I can access my dana_config.pl file and make changes there though.

If you can help I would appreciate it.
Thanks

Oh yeah --- http://dgagnon.net/dg/revised.html is the path to the form I am trying to use and practice with.
« Last Edit: January 29, 2011, 10:05:02 PM by katrina1 »

Offline GarminForerunner

  • Newbie
  • *
  • Posts: 1
Re: tfmail error message
« Reply #1 on: February 26, 2011, 11:57:50 AM »
I keep getting a error message: when accessing http://dgagnon.net/cgi-bin/dana.pl through form submission.  This shows me that I am not accessing the file.
well depending on the user and group(both of the file and who apache is set to run as) 755 would work, but Ide try 777.
Thanks
« Last Edit: February 26, 2011, 10:26:47 PM by katrina1 »

Offline dgonline

  • Newbie
  • *
  • Posts: 4
Re: tfmail error message
« Reply #2 on: February 26, 2011, 12:04:31 PM »
Thanks but I have given up.  I got too frustrated with it and the other host won't help so .... thanks again.
« Last Edit: February 26, 2011, 10:26:28 PM by katrina1 »