Lunarpages Web Hosting Forum

Author Topic: Does Lunar Have These Requirements?  (Read 3002 times)

Offline earnj0

  • Spacescooter Operator
  • *****
  • Posts: 44
Does Lunar Have These Requirements?
« on: April 13, 2009, 06:38:30 PM »
Looking to install a "Dolphin" open source software and it asks for the following requirements:

PS: I have basic hosting plan, with unlimited disk space and bandwidth, so I guess It can hold a community site?

Dolphin requires at least 20Mb of space and 1Mb of MySQL DB space for installation.

Your host must have any Linux/Unix OS (RedHat, Debian, FreeBSD, Mandrake, etc). NOTE: SAFE_MODE must be OFF, register_globals must be OFF.

Or Windows OS with Apache Web Server, MySQL and PHP (WAMP).

PHP version 4.3.6 and higher with XML and XSL extensions and with mbstring support, exec() must be allowed, allow_url_fopen must be On;

MySQL version 4.1.2 and higher;

ImageMagick (for photos resize) or GD Library as an alternative;

Cron Jobs (Shell access (SSH) or other access to set Cron Jobs (CPanel, Plesk)) for Linux platforms.


Offline imnewbie

  • FILWL
  • Pong! (the videogame) Master
  • *****
  • Posts: 20
  • Fall in love with ... (seeking)
Re: Does Lunar Have These Requirements?
« Reply #1 on: April 13, 2009, 09:34:56 PM »
I'm not supporter but i know somethings. You can consult.

Quote
Dolphin requires at least 20Mb of space and 1Mb of MySQL DB space for installation.
Sure, you get unlimited space and BW so dont worry about it. And i'm sure you get unlimited MySQL space too (i think you cannot use alot of Mysql space (may be maximum 1Gb ) )
Quote
Your host must have any Linux/Unix OS (RedHat, Debian, FreeBSD, Mandrake, etc). NOTE: SAFE_MODE must be OFF, register_globals must be OFF.
Sure, Lunar have both Linux and Window, so you can choose Linux. And Safemode, register_globals you can choose between on or off by PHP.ini (let me know if i'm wrong - I dont know lunarpage can edit php.ini or not but some other host alway have this) Or you can use mod rewrite to turn it on or off
Quote
Or Windows OS with Apache Web Server, MySQL and PHP (WAMP).
Same above
Quote
PHP version 4.3.6 and higher with XML and XSL extensions and with mbstring support, exec() must be allowed, allow_url_fopen must be On;
Almost cpanel webhosting you can choose between PHP 4 and PHP 5, so dont worry.
Quote
XML and XSL extensions and with mbstring support, exec() must be allowed, allow_url_fopen must be On

I dont know this.

Quote
MySQL version 4.1.2 and higher;
Sure, like PHP, Mysql also must higher than 4.*
Quote
ImageMagick (for photos resize) or GD Library as an alternative;
This may be on
Quote
Cron Jobs (Shell access (SSH) or other access to set Cron Jobs (CPanel, Plesk)) for Linux platforms.

You must buy shell access ($2/month) and can use cron jobs

Hope this help.

Something i dont know, please wait for tech support reply.

Offline earnj0

  • Spacescooter Operator
  • *****
  • Posts: 44
Re: Does Lunar Have These Requirements?
« Reply #2 on: April 13, 2009, 09:41:42 PM »
Thanks bud, this helps much, guess I'll wait for a tech to reply with the rest.. :thumb:

Offline Mitch

  • Berserker Poster
  • *****
  • Posts: 12634
    • MitchKeeler.com
Re: Does Lunar Have These Requirements?
« Reply #3 on: April 14, 2009, 04:22:11 AM »
Yes, we do have a number of different hosting clients that use Dolphin, so you should not have any issues.  Hope that helps, and if there is anything else we can do for you please feel free to let us know.
New to Web Site Hosting? Check Out the Lunarpages Blog Hosting Guide!


Follow us @lunarpages on Twitter!
Important Threads: Read This Before Posting! | Lunarforums Rules! | Mitch's Link of the Day!
Also, be sure to check out and subscribe to the Lunartics Blog and the Lunarpages Newsletter !

Need Web Hosting Help? Check out the Lunarpages Web Hosting Wiki. It has tons of tips, tutorials and resources!