Lunarpages Web Hosting Forum

Author Topic: Cant Get any CGI Scripts (mainly CGIEMAIL) to work  (Read 2455 times)

Offline aarco3

  • Newbie
  • *
  • Posts: 1
Cant Get any CGI Scripts (mainly CGIEMAIL) to work
« on: March 31, 2008, 12:39:23 AM »
Hi,

I have been attempting to set up a cgi email script, but have been having troubles getting the script to work. I originally tried a script that I had found on the internet, but continually got a 404 error when i tried to send the data to the location of the script (in cgi-bin directory). I have now been trying the CGI EMAIL script but have been having similar results. It seems that I cannot access anything inside my cgi-bin folder.

The permissions of the script are set to 755 like the guide says, and the script has not been modified. It is as it was when I found it.

I have been using the MIT Guide to try and install CGIEMAIL that comes with lunar pages hosting. The guide can be found here: http://web.mit.edu/wwwdev/cgiemail/user.html

The guide says to test the email text file first. I tried this and it worked: http://aarconsult.net/registration.txt

The guide then says to add the cgiecho location to the file name. This gives a 404 error, even though the file is located in the cgi-bin directory. The address I have been using is: http://aarconsult.net/cgi-bin/cgiecho/registration.txt

I also can't type in the direct location of the cgiecho file http://aarconsult.net/cgi-bin/cgiecho without a 404 error.

Finally, i decided to try and create the form anyway. However when I try to send the data, i get a 404 error because it cannot find cgiecho. The address for the registration form is: http://aarconsult.net/registration.html

I believe I have been following the guide correctly, and have tried to follow all steps correctly, but I cannot find out what is causing the 404 error.

I hope someone can help me. If you need anything extra, dont hesitate to ask.

Thanks heaps,

Ricky