Lunarpages Web Hosting Forum

Author Topic: Error nobody@lunarpages  (Read 1965 times)

Offline charlig69

  • Space Explorer
  • ***
  • Posts: 9
Error nobody@lunarpages
« on: June 13, 2006, 06:42:21 AM »
I keep getting this error. My form is working but the email address always saids nobody@lunarpages.com  :? I have a field within my form where users insert their email address and i thought nms will take that as the "from " field but it doesnt help plz.
Quote
BEGIN
{
  $DEBUGGING         = 0;
  $emulate_matts_code= 0;
  $secure            = 1;
  $allow_empty_ref   = 1;
  $max_recipients    = 5;
  $mailprog          = '/usr/sbin/sendmail -oi -t';
  $postmaster        = '';
  @referers          = qw(www.tiffinfranciscans.org localhost);
  @allow_mail_to     = qw(carlosg@tiffinfranciscans.org localhost);
  @recipients        = ();
  %recipient_alias   = ();
  @valid_ENV         = qw(REMOTE_HOST REMOTE_ADDR REMOTE_USER HTTP_USER_AGENT);
  $locale            = '';
  $charset           = 'iso-8859-1';
  $date_fmt          = '%A, %B %d, %Y at %H:%M:%S';
  $style             = '/css/nms.css';
  $no_content        = 0;
  $double_spacing    = 1;
  $wrap_text         = 0;
  $wrap_style        = 1;
  $address_style     = 0;
  $send_confirmation_mail = 0;
  $confirmation_text = <<'END_OF_CONFIRMATION';
From: carlosg@tiffinfranciscans.org
Subject: form Submission

There is my file template1.pl and permissions 755.

Offline GMTurner

  • Berserker Poster
  • *****
  • Posts: 7479
    • Turner's Lounge
Re: Error nobody@lunarpages
« Reply #1 on: June 13, 2006, 07:56:23 AM »
Take a look at step 2 in this how-to thread and see if that helps...

http://www.lunarforums.com/forum/index.php?topic=18221.0

basically, the field in the html form has to be called "email" for it to work...
The above information may or may not reflect current policy, opinions, or views since it was likely made almost 10 years ago.

Offline charlig69

  • Space Explorer
  • ***
  • Posts: 9
Re: Error nobody@lunarpages
« Reply #2 on: June 13, 2006, 08:41:18 AM »
Thxs. I had it working before but I changed the id field to Email and then to something else , but it is working fine now. "email" it is.
Thxs :)


Offline GMTurner

  • Berserker Poster
  • *****
  • Posts: 7479
    • Turner's Lounge
Re: Error nobody@lunarpages
« Reply #3 on: June 13, 2006, 10:32:50 AM »
Glad it worked :thumb:

(Also, special thanks again to Leighsww for the excellent how-to on setting up NMS formmail :) )
The above information may or may not reflect current policy, opinions, or views since it was likely made almost 10 years ago.

Offline philvis

  • Master Jedi
  • *****
  • Posts: 1005
Re: Error nobody@lunarpages
« Reply #4 on: June 15, 2006, 12:45:12 PM »
I'm using a Flash form with the NMS FormMail script and naming the email field email still returns the email addy as nobody @ server . lunarpages.
Other than that, the form works but its a little irritating.
Anyone have a solution for this problem?

Offline GarveysIT

  • Web Design SEO England UK
  • Berserker Poster
  • *****
  • Posts: 11648
  • Web Design SEO England UK
    • Web Design | SEO | IT Support Stockton-on-Tees, Middlesbrough, Darlington, Durham
Re: Error nobody@lunarpages
« Reply #5 on: June 15, 2006, 12:51:22 PM »
can you give a link?

Offline philvis

  • Master Jedi
  • *****
  • Posts: 1005
Re: Error nobody@lunarpages
« Reply #6 on: June 15, 2006, 12:56:29 PM »
I'm testing it. I'll throw one up in a few minutes.

Offline philvis

  • Master Jedi
  • *****
  • Posts: 1005
Re: Error nobody@lunarpages
« Reply #7 on: June 15, 2006, 01:11:34 PM »
Here's the link.

Offline GarveysIT

  • Web Design SEO England UK
  • Berserker Poster
  • *****
  • Posts: 11648
  • Web Design SEO England UK
    • Web Design | SEO | IT Support Stockton-on-Tees, Middlesbrough, Darlington, Durham
Re: Error nobody@lunarpages
« Reply #8 on: June 15, 2006, 01:15:52 PM »

Offline philvis

  • Master Jedi
  • *****
  • Posts: 1005
Re: Error nobody@lunarpages
« Reply #9 on: June 15, 2006, 01:19:13 PM »
No, the field is email, not e-mail. I think NMS FormMail requires it to be such. I'll try the other way.

Offline GarveysIT

  • Web Design SEO England UK
  • Berserker Poster
  • *****
  • Posts: 11648
  • Web Design SEO England UK
    • Web Design | SEO | IT Support Stockton-on-Tees, Middlesbrough, Darlington, Durham
Re: Error nobody@lunarpages
« Reply #10 on: June 15, 2006, 01:20:15 PM »
no sorry about that, i meant email

did you check the steps of this:

http://www.lunarforums.com/forum/index.php?topic=18221.0
?

Offline philvis

  • Master Jedi
  • *****
  • Posts: 1005
Re: Error nobody@lunarpages
« Reply #11 on: June 15, 2006, 01:26:22 PM »
It works now. Thanks.

I realized it when I got your test email with a valid email address. Out of pure and utter laziness... :oops: ... I wasn't entering a valid email addy when testing. Live and learn.

Offline GarveysIT

  • Web Design SEO England UK
  • Berserker Poster
  • *****
  • Posts: 11648
  • Web Design SEO England UK
    • Web Design | SEO | IT Support Stockton-on-Tees, Middlesbrough, Darlington, Durham
Re: Error nobody@lunarpages
« Reply #12 on: June 15, 2006, 01:29:01 PM »
glad i could help! :)