Lunarpages Web Hosting Forum

Author Topic: NMS help!  (Read 10481 times)

Offline parish2

  • Spaceship Navigator
  • *****
  • Posts: 93
NMS help!
« Reply #30 on: August 20, 2004, 04:10:59 PM »
But it won't work when you try to fill it out on my site.  So that's still a problem.  What do you think?  Should I start looking for another cgi script?

leighsww

  • Guest
NMS help!
« Reply #31 on: August 20, 2004, 04:25:41 PM »
Yikes, you would have to find one acceptable with LP otherwise they'll disable it. And, I'm sorry but if you try to install TFMail, I warn you that will be an even bigger headache.

Let's try something ...

Do you have another email account like yahoo.com or something?  Cuz, someone had a similar problem with not being able to get the return email with their LP email addy, but was able to get it with their yahoo.com addy.

So, if you do have another email addy we can temporarily substitute it to check out if this is the problem for you, too.

Offline parish2

  • Spaceship Navigator
  • *****
  • Posts: 93
NMS help!
« Reply #32 on: August 21, 2004, 06:46:48 AM »
Yes, I have many other accounts, including AOL, a business account and a school account.  

So where do I have to substitue these?  In both the page's HTML and in the cgi script?

leighsww

  • Guest
NMS help!
« Reply #33 on: August 21, 2004, 09:16:33 AM »
Only enter it in the script for the @allow_mail_to variable.

Try using the business account email addy first.

Offline parish2

  • Spaceship Navigator
  • *****
  • Posts: 93
NMS help!
« Reply #34 on: August 21, 2004, 10:39:52 AM »
Well maybe this is the problem  Right now it says:

 @allow_mail_to @recipients %recipient_alias

Can you tell me exactly how to change it?

thx

leighsww

  • Guest
NMS help!
« Reply #35 on: August 21, 2004, 10:54:26 AM »
Are you saying that they are strung all on the same line?

If that's the case, then I recommend that you get the "original" script again, make your changes to the configs and upload the new one.  Make sure you upload in ASCII (if using an FTP client) and don't forget to chmod to 755.

Oh wait, are you looking above the debugging?  ONLY add your email addy to the one in the CONFIGURATION section, where your previous email addy shows.

Offline parish2

  • Spaceship Navigator
  • *****
  • Posts: 93
NMS help!
« Reply #36 on: August 21, 2004, 11:05:09 AM »
OK.  When I change the name of the file from TFmail, does it matter that the word TFmail appears withing the file itself?  Do I have to search/replace all occurences, or is it only the title that matters?

Offline parish2

  • Spaceship Navigator
  • *****
  • Posts: 93
NMS help!
« Reply #37 on: August 21, 2004, 11:10:23 AM »
And is my user name parish2 or parishomeawayfromhome?

leighsww

  • Guest
NMS help!
« Reply #38 on: August 21, 2004, 11:15:29 AM »
Are you now switching script and using TFMail?  :(

Hmmmm.  I'm not going to help you with that script if you do so.

Okay, at this point, here's what I think it best we do.  Create a user FTP account for me and give me access to your "cgi-bin". So, when you create the user, replace the default path it automatically puts in and type /cgi-bin in it's place.  That will give me access to ONLY your cgi-bin.

Then PM me the username and password.

I will fix that script for you until we get it working.  It's too hard the way we are doing it now, cuz it seems you are making things worst if you don't know what you are doing or where I tell you to make the changes.

Offline parish2

  • Spaceship Navigator
  • *****
  • Posts: 93
NMS help!
« Reply #39 on: August 21, 2004, 11:28:09 AM »
:argh: I feel so stupid.  I meant to get the NMS script, but I got confused.  Let me give it one more try.

Offline parish2

  • Spaceship Navigator
  • *****
  • Posts: 93
NMS help!
« Reply #40 on: August 21, 2004, 12:09:07 PM »
OK, I'm back where I started.  Here's the relevant part of the script I uploaded, renamed reserve.pl:

BEGIN
{
  $DEBUGGING         = 1;
  $emulate_matts_code= 0;
  $secure            = 1;
  $allow_empty_ref   = 1;
  $max_recipients    = 5;
  $mailprog          = '/usr/sbin/sendmail -oi -t';
  $postmaster        = '';
  @referers          = qw(parishomeawayfromhome.com 216.193.194.212 localhost);
  @allow_mail_to     = qw(jeffrey@parishomeawayfromhome.com localhost);
  @recipients        = ();
  %recipient_alias   = ();
  @valid_ENV         = qw(REMOTE_HOST REMOTE_ADDR REMOTE_USER HTTP_USER_AGENT);
  $locale            = '';
  $charset           = 'iso-8859-1';
  $date_fmt          = '%A, %B %d, %Y at %H:%M:%S';
  $style             = '/css/nms.css';
  $no_content        = 0;
  $double_spacing    = 1;
  $wrap_text         = 0;
  $wrap_style        = 1;
  $address_style     = 0;
  $send_confirmation_mail = 0;
  $confirmation_text = <<'END_OF_CONFIRMATION';
From: jeffrey@parishomeawayfromhome.com
Subject: form submission

Thank you for your form submission.

END_OF_CONFIRMATION

# You may need to uncomment the line below and adjust the path.
# use lib './lib';

# USER CUSTOMISATION SECTION
# --------------------------
# Place any custom code here

And my HTML code is:

<form method="post" action="/cgi-bin/reserve.pl">

Did I miss something?  Because is still isn't working.

Let me know if you want to take over the controls at any time.  I'm so grateful for all your help already.

leighsww

  • Guest
NMS help!
« Reply #41 on: August 21, 2004, 12:16:46 PM »
If it's still not working, then let me have access.

If you need reassurance of my integrity, to give me access to your server, you can read these two testimonial pages on my website which will hopefully make you feel comfy with trusting me  :D :

* links were removed as it is no longer needed

Once you feel okay about me, create the user FTP account and PM me the info. Oh and include all your other email addys so I can insert them so we can test each one out to see if any of them will work.

leighsww

  • Guest
NMS help!
« Reply #42 on: August 21, 2004, 12:48:34 PM »
Hmmm, it's not letting me in.  Did you give me access to the cgi-bin folder?  You have to erase what it defaults to in the "directory" area and type in /cgi-bin before you click the "Create" button.

So it should look like:

Directory: /home/username/public_htm/cgi-bin

You may have to delete it and do it again.  Please just give me an easy password, like "test".  It's only going to be temporary and nobody is gonna be able to get in, so it doesn't have to be so lengthy and complicated.

Also, I'll need you to PM me your other email addys cuz that's what I'll need to test if you can get emails to one of those.

Offline parish2

  • Spaceship Navigator
  • *****
  • Posts: 93
NMS help!
« Reply #43 on: August 21, 2004, 02:52:43 PM »
I'm sorry for being so dense, but I can't figure out how to do that.  I'm in the FTP Manager, right?  Under FTP ACCOUNTS / Add Account, the only directory option is /home/parish2/public_html____________.  Is that where I put leighs2/public_htm/cgi-bin?

leighsww

  • Guest
NMS help!
« Reply #44 on: August 21, 2004, 02:56:34 PM »
No, you just put --> /cgi-bin

That's all you need to put. Just the folder name that you want me to access.