Lunarpages Web Hosting Forum

Author Topic: error opening subsilver.cfg  (Read 1735 times)

Offline 6T7

  • Pong! (the videogame) Master
  • *****
  • Posts: 21
    • http://www.FORDification.com
error opening subsilver.cfg
« on: July 25, 2004, 01:11:12 AM »
I was installing a online/offline/hidden mod to my phpBB this evening. One of the files which needed editing was 'subsilver.cfg' file. I edited it, uploaded it to the server, and everything was doing great. Then all of a sudden, when trying to access my board, I get the following error message:
=====================================

phpBB : Critical Error

Could not open subSilver template config file

DEBUG MODE

Line : 326
File : /home/oldsmo2/public_html/ford/forum/includes/functions.php

=====================================

I then uploaded the good copy I had, thinking maybe it got corrupted. Got the same message. I then uploaded a completely unedited copy of this file but get the same message. The file is in the correct directory...so what's going on? No matter what  version of this file I reupload, I get this error message. Can someone PLEASE point me in the right direction? I'm lost and now my forum is offline!  :cry:

The forum in question is located at http://www.fordification.com/forum/

katrina1

  • Guest
error opening subsilver.cfg
« Reply #1 on: July 25, 2004, 04:48:35 AM »
Hi. I see // Start add - Online/Offline/Hidden Mod in it still. Are you sure you uploaded the old copy? If you used File Manager, you have to tell it to overwrite the old file. Did you edit functions.php at all?

Offline MishaPappa

  • Jabba the Hutt
  • *****
  • Posts: 583
error opening subsilver.cfg
« Reply #2 on: July 25, 2004, 07:24:35 AM »
It appears to me that you may have uploaded/given the file a wrong name.

It should be named: subSilver.cfg

The naming is case sensitive so be sure that the second "S" is capitalized!

My conclusion is based upon the fact that URL #1 below opens the file while URL #2 encounters an error 404.

URL #1 - http://www.fordification.com/forum/templates/subSilver/subsilver.cfg
URL #2 - http://www.fordification.com/forum/templates/subSilver/subSilver.cfg

All phpBB forum configurations I've got running require the noted naming convention.
"I know that you understood what you think I said but I'm not sure you realize that what you heard is not what I meant..."

Andromeda, April 2003 - Sept 2004
Lyra, since Sept 2004

Misha

Offline 6T7

  • Pong! (the videogame) Master
  • *****
  • Posts: 21
    • http://www.FORDification.com
error opening subsilver.cfg
« Reply #3 on: July 25, 2004, 07:24:41 AM »
katrina1: Thanks for your time. I was up until almost 5 AM trying many different things....the version which got left on the server before I finally gave up was a copy of the master which I tried editing for the mod through the Control Panel instead of locally with WordPad, thinking that possibly something was happening to it during FTP uploading.

I've only got two mods (including this one) installed, neither of which required any editing of the functions.php file. The other mod (PM mod) did also require adding two lines into the subSilver.cfg which are still marked with comments. I tried deleting those two lines PLUS the Online/Offline mod edits, both locally with WordPad and with a master copy with the Control Panel, but continued to get the same error.   :?   :cry:

Offline MishaPappa

  • Jabba the Hutt
  • *****
  • Posts: 583
error opening subsilver.cfg
« Reply #4 on: July 25, 2004, 07:28:54 AM »
Looks like we posted simultaneously!!

Hopefully, you'll read my earlier one and it will provide a resolution direction!
"I know that you understood what you think I said but I'm not sure you realize that what you heard is not what I meant..."

Andromeda, April 2003 - Sept 2004
Lyra, since Sept 2004

Misha

Offline 6T7

  • Pong! (the videogame) Master
  • *****
  • Posts: 21
    • http://www.FORDification.com
error opening subsilver.cfg
« Reply #5 on: July 25, 2004, 07:31:53 AM »
THAT WAS IT! :yey: Thank you thank you thank you! I'm not entirely sure how the filename case was changed, since I don't specifically recall doing it, but I will most DEFINITELY watch that issue from here on out. I ran into this issue yesterday with missing webpage graphics too, which turned out to be the extension case, so I SHOULD have thought about that.

Man, those Linux servers ain't very forgiving over little errors, are they? No problem, I'll make sure this doesn't happen again! Thanks again!

katrina1

  • Guest
error opening subsilver.cfg
« Reply #6 on: July 25, 2004, 07:01:32 PM »
One last thing, do NOT edit with WordPad. You must use a text editor such as Notepad. If you use a word processor, they tend to put hidden carriage returns, spaces, etc.

Offline TranzNDance

  • Princess of Naboo
  • Berserker Poster
  • *****
  • Posts: 11567
    • Thu Tu's Blog
error opening subsilver.cfg
« Reply #7 on: July 25, 2004, 07:14:30 PM »
I find that using WordPad is fine as long as one remembers to save as a text document type. NotePad can't always read some files' line breaks properly and shows them as rectangles. Also NP can't do drag and drop, or highlight full lines by clicking in the area to the left of the line. It can't delete complete words with ctrl+backspace. Another optional caveat to using WP is to "Paste Special / unformatted text" after copying formatted text to avoid the prompt about losing formatted text when saving in text-only mode.
:whip: :love: :whip: :love: :whip: :love: