Lunarpages Web Hosting Forum

Author Topic: When browsing a PHP page, it jumps where PHP code begins  (Read 680 times)

Offline sv800

  • Intergalactic Cowboy
  • *****
  • Posts: 51
    • http://www.vialin.com
When browsing a PHP page, it jumps where PHP code begins
« on: May 06, 2004, 08:05:59 AM »
When displaying a PHP page, it jumps where PHP code begins
here is the page:
http://www.peoplecnc.com/index.php

My page start displaying the html code, then it jumps where
the PHP code is, I would like my page to stay at the header of my
my page and then user scrolls down.

Would like to avoid this effect.
Thanks.

Offline mtbkanata

  • Pong! (the videogame) Master
  • *****
  • Posts: 20
    • http://www.mtbkanata.com
When browsing a PHP page, it jumps where PHP code begins
« Reply #1 on: May 06, 2004, 08:20:50 AM »
Now that's strange!  I can't see anything in the HTML source which would drop your page.. did that just start happening?  (Did your server have the php upgrade?)

Offline MishaPappa

  • Jabba the Hutt
  • *****
  • Posts: 583
When browsing a PHP page, it jumps where PHP code begins
« Reply #2 on: May 06, 2004, 08:23:51 AM »
The page loads and appears to jump straight to the Stock Symbol input field for me (where PSFT is already input).... Could it be this javascript causing the problem?
Code: [Select]
<script>
document.stockm.Symbol.focus();
</script>
"I know that you understood what you think I said but I'm not sure you realize that what you heard is not what I meant..."

Andromeda, April 2003 - Sept 2004
Lyra, since Sept 2004

Misha

Offline mtbkanata

  • Pong! (the videogame) Master
  • *****
  • Posts: 20
    • http://www.mtbkanata.com
When browsing a PHP page, it jumps where PHP code begins
« Reply #3 on: May 06, 2004, 08:47:55 AM »
Oh, that's probably it!  That's where my cursor goes too... I did it with different window sizes, and it moves always to the same spot..

Offline sv800

  • Intergalactic Cowboy
  • *****
  • Posts: 51
    • http://www.vialin.com
Yes, it was the cause
« Reply #4 on: June 14, 2004, 04:52:45 AM »
Quote from: mtbkanata
Oh, that's probably it!  That's where my cursor goes too... I did it with different window sizes, and it moves always to the same spot..


Yes, the cursor stuck there.
Now, Yahoo ERP News changed, and my grabbing script is not working. Need to go back to code.
Thanks for the help.