Lunarpages Web Hosting Forum

Author Topic: chmod problem making it impossible to...  (Read 407 times)

Offline StuartM

  • Newbie
  • *
  • Posts: 2
chmod problem making it impossible to...
« on: April 07, 2004, 09:58:07 AM »
Hi. I'm having a problem with chmod'ing in my FTP. I run a news script and it asks that the folder that hosts the news file be chmod'ed to 777, which it is, and all files within the folder to 666... which they were. But now some of them are 644 and 777, and it isn't letting me post news because of the permissions. I tried to change them, but for newer ones I keep getting the same error message.

"SITE CHMOD 670 /www/news/news/news.1335.php
550 Could not change perms on /www/news/news/news.1335.php: Bad file descriptor"

I've searched, but can't find any solutions, and until I can find one, my site basically can't be updated. I'd greatly appreciate the help of anyone as soon as possible. Thanks.

Offline Johnny

  • MR-Disabled
  • Über Jedi
  • *
  • Posts: 1891
chmod problem making it impossible to...
« Reply #1 on: April 07, 2004, 10:49:15 AM »
If you're on Leo, you might want to check this link out:
http://www.lunarforums.com/forum/viewtopic.php?t=13834

If not, you may want to see if LP has implemented this on the server you're on.

Offline StuartM

  • Newbie
  • *
  • Posts: 2
chmod problem making it impossible to...
« Reply #2 on: April 07, 2004, 11:10:51 AM »
Hi. I've read it, and I'm still not actually sure what I'm supposed to do. :argh:

I'm not very good at this stuff, my knowledge is pretty limited. What I did notice is that older files in the news directory will chmod no problems, but newer ones won't. I found that really strange. I created a blank php.ini file (one of the things I was able to comprehend from that link) and placed it where specified, but it did nothing...

Offline Max

  • Über Jedi
  • *****
  • Posts: 2506
    • Max's website!
chmod problem making it impossible to...
« Reply #3 on: April 07, 2004, 11:47:27 AM »
support should be able to help you, please indicate you are on leo and you seem have some issues with the php suexec.