Lunarpages Web Hosting Forum

Author Topic: PHP 7.1 support on LP domains/  (Read 121 times)

Offline Freewheeler.Ken

  • Newbie
  • *
  • Posts: 2
PHP 7.1 support on LP domains/
« on: January 04, 2019, 01:25:01 PM »

When will PHP 7.1 be available here? Scripts are returning errors due to deprecated functions.

Error
We have detected that your server is using PHP 7.0.33 which is obsolete and no longer receives official security updates by its developers. The Joomla! Project recommends upgrading your site to PHP 7.1 or later which will receive security updates at least until 2019-12-01. Please ask your host to make PHP 7.1 or a later version the default version for your site. If your host is already PHP 7.1 ready please enable PHP 7.1 on your site's root and 'administrator' directories typically you can do this yourself through a tool in your hosting control panel, but it's best to ask your host if you are unsure.

Offline MrPhil

  • Senior Moderator
  • Berserker Poster
  • *****
  • Posts: 6380
Re: PHP 7.1 support on LP domains/
« Reply #1 on: January 04, 2019, 03:19:24 PM »
At least, you're already at 7.0. My server is stuck at 5.6, and there's no word on when it will be updated. They tell me it's "in the works", but won't say when. Considering that everything less than 7.1 is out of support, this is absurd.

If you are getting "deprecated" warnings, upgrading PHP is only going to make it worse. Your software (such as Joomla) needs to be upgraded to match the PHP you have now (7.0). Joomla is telling you to go to 7.1 because that's what is supported, not because it will get rid of "deprecated" errors. Simply upgrading to 7.1 is only going to make the current errors worse.
Visit My Site

E-mail Me
-= From the ashes shall rise a sooty tern =-