Lunarpages Web Hosting Forum

Scripting Languages Hosting Help => PHP and MySQL Support => Topic started by: Tom Veik on September 03, 2017, 12:37:29 PM

Title: Edit using phpMyAdmin
Post by: Tom Veik on September 03, 2017, 12:37:29 PM
It's been a while since I've worked on my database.  I used to be able to easily edit individual entries in my database using phpMyAdmin, but now the pencil/edit icon doesn't show up on the browse screen.  How do I get that edit icon back?  Or am I looking in the wrong place?  I've been rooting around for a while now and I'm not figuring this out.

Tom
Title: Re: Edit using phpMyAdmin
Post by: MrPhil on September 03, 2017, 02:03:19 PM
You selected a database, then selected a table, then clicked "Browse" on that table? And no "Edit" pencil for each  entry? Odd... it works fine for me (under cPanel). Did anyone change table or database permissions to Read-Only in some way? I don't think there's a "user" associated with phpMyAdmin, so no user permissions to look at. Is the database working fine otherwise (and you can make queries in the SQL window)?
Title: Re: Edit using phpMyAdmin
Post by: Tom Veik on September 03, 2017, 04:19:03 PM
You selected a database, then selected a table, then clicked "Browse" on that table? And no "Edit" pencil for each  entry?
Is the database working fine otherwise (and you can make queries in the SQL window)?
That's correct.  The database works fine from my PHP code and I can make SQL queries in the SQL query window, but there are no pencil/edit icons next to each record row in Browse.

Am I missing a setting somewhere?
Title: Re: Edit using phpMyAdmin
Post by: Tom Veik on September 03, 2017, 07:01:06 PM
Figured it out.  It was complaining that I didn't have a unique column, even though I did have a unique column.  Anyway, I added another column and made it auto increment.  Now I have the edit buttons back.  So I'm good now.