Lunarpages Web Hosting Forum

Scripting Languages Hosting Help => C++ / PERL / CGI Support => Topic started by: vevima on July 28, 2013, 04:50:24 PM

Title: Perl can't connect to MySQL 5.5
Post by: vevima on July 28, 2013, 04:50:24 PM
Hi,
Recently I got a message saying that MySQL on server (STYX) was getting upgraded to version 5.5.
I have old Perl scripts( that have been working forever ) that now fail !?!?
They use DBI to connect to MySQL. They get a database handle using this function:
$dbh = DBI->connect("DBI:mysql:database_name:localhost","username","password")

Can you please help? Thanks.
Marc

Title: Re: Perl can't connect to MySQL 5.5
Post by: sofo on November 02, 2013, 03:57:42 AM
I hope to find help in solving the problem


Title: Re: Perl can't connect to MySQL 5.5
Post by: MrPhil on November 05, 2013, 09:43:40 AM
I realize this topic is fairly old, but "now fails" doesn't give us much to go on. Are you getting specific error messages? If so, does http://dev.mysql.com/doc/refman/5.5/en/perl-support-problems.html help? Most of those items would have to be handled by LP's techs (recompiling Perl, installing missing modules, etc.). It's possible that they are unaware of Perl libraries needing to be upgraded at the same time as the MySQL upgrade, or they missed a server.