Lunarpages Web Hosting Forum

Specialized Hosting Needs and Services => Dedicated Web Hosting at Lunarpages => Topic started by: Chaos Dragon on October 21, 2009, 03:52:38 PM

Title: root and crontabs perms quetion and JRE again?
Post by: Chaos Dragon on October 21, 2009, 03:52:38 PM

 I have a new question? I am wondering about permissions in the root? Would I still use 755 instead of 777 in the root or should I be using 777 instead. I am not sure about this since everything in the install instructions state chmod 777 to give permissions to the executable files and certain others.
All install lit points towards 777 permission for certain files as per install lit for certain software such as a Forum script or Social network script will state to use 777 or 666 permissions but if your running a certain php such as suPHP you should use 644 and 755 permissions instead.
Just right now I am not sure if it is running right or not since I can't seem to find anything about the root permissions and which I should use. Also as far as I can tell if they are the wrong permissions (755) it is not affecting any thing. Now in the public_html I must use 644 and 755 on certain files to work properly that hasn't changed from the Shared server I upgraded from.
And next question is how do I set my crontabs from 6755 to 4755 which it has a warning for when I go to Cron Jobs. I tried chmod -v 4755 crontabs in my terminal but didn't make a difference unless I needed to reboot or restart and also I didn't get a conformation that the permissions have changed and no error also cause when I typed the command I was in the proper directory where contabs is located cause I used the find command to find the path to crontabs so I could locate to change permissions.
Now I did try to install JRE and went through the install and everything and once I got the file extracted and did the command to install using the .rpm which I was informed to use when I called support, it said it was already installed. In the install lit it stated that it would be installed in /usr/java/jre.1.6.0_16,
and sure enough it was there, but nothing about JDK though.
Now here is what really got me confused when looking through some of the files for the RMS I am trying to install, they had this tag in them <beans></beans>.  Should I be running a JRE or JDK with beans?
Now I think I have asked the all the questions I needed for right now, but I am sure I'll be back to ask more.
Thank You in advance for any answers to these questions.

Title: Re: root and crontabs perms quetion and JRE again?
Post by: perestrelka on October 21, 2009, 08:34:43 PM

For the file system permissions, can you please specify what is the type of the files you are talking about asking for suitable permissions or maybe you meant folders?

JRE and JDK are different things. JDK includes JRE and is usually required, if there will be java code compilation required. JRE is enough, if you already have java binaries and only need something to run them.
Title: Re: root and crontabs perms quetion and JRE again?
Post by: Chaos Dragon on October 21, 2009, 08:39:40 PM
the type of files I speak of are files such as these for example.
and other .exe file extensions and
jre-6u16-linux-i586-rpm.bin and so forth.

Title: Re: root and crontabs perms quetion and JRE again?
Post by: Chaos Dragon on October 22, 2009, 01:35:14 PM
Ok figured out the permissions for root thing I think.
Ok here is the run down.
1. I was trying to install RMS(Ray Media Server) that needs to be installed in the root.
2. Once I got it running or at least I thought it was until I tried. At this time I had permissions 755 for these files
3. Did the required info in to the Flash Apps Panel for Ray widgets (Chat, White Board, IM, and Profile Videos). In other words I need to put my server IP for RMS then put the port number and HTTP port number then save settings. I then get Can't Connect to RMS.
4. I went in and switched the permissions for *.sh and ffmpeg.exe from 755 to 777 and then re added the info in Flash Apps Panel Clicked save and it connected.

RMS is just an extension file that is needed to run Chat, IM, White Board, and to be able to record profile Videos for a Social Network Software. Also I thought maybe I installed JRE wrong or something also, but that wasn't the case.
Actually when I tried to install JRE 1.6_16 it was already installed. Didn't know that until I tried installing. I ended up finding the path reading some more on the install lit and at the end it stated that when you install jre it will be installed into /usr/java so I looked. It was there. I assumed since I created the directory in my root and put the install file there and ran the install procedure it would install into that root directory I created. I learned something....  :smiling:
So that is as far as I can tell been cleared up.

Now as for my Cron Jobs contabs permission settings.
When I go in to Cron Jobs I see a permissions warning for the file crontabs. It states that permissions are 6755 and should be 4755 and I should change them. I tried chmod -v 4755 crontabs, but nothing happened, no conformation that permissions have been changed and still have the warning.



Title: Re: root and crontabs perms quetion and JRE again?
Post by: perestrelka on October 22, 2009, 10:32:29 PM

It is great to hear your solve the issue with RMS and java install.

As for the crontab, try changing the permissions using the full path to the file - /usr/bin/crontab