Lunarpages Web Hosting Forum

Scripting Languages Hosting Help => C++ / PERL / CGI Support => Topic started by: ked on December 24, 2006, 04:19:52 PM

Title: Re: Setting up NMS FormMail
Post by: ked on December 24, 2006, 04:19:52 PM
Hi,
i am stuck with new problem with formmail.....i decided to follow the instructions here and now i am receiving the following error...

'Application Error
An error has occurred in the program

Can't open mailprog [/usr/lib/sendmail -oi -t] '

I am using windows server.....So please help....

Thanks in advance....
Ked

Title: Re: Setting up NMS FormMail
Post by: leighsww on December 24, 2006, 04:47:10 PM
Ked -

Since you're on a Windows server, did you change your "shebang" line and $mailprog configs to what it says in this following post? --> Click here (http://www.lunarforums.com/lunarpages_c_perl_cgi/formmailpl_bad_gateway-t33731.0.html;msg253395#msg253395)
Title: Re: Setting up NMS FormMail
Post by: ked on December 25, 2006, 04:43:20 PM
Hi,
I had changed the shebang line...but i didn't change the mailprog line as per the instructions..hence seems i was getting the error........but as u said i checked the forum messages again....now changed the line as ...

..... $mailprog          = 'SMTP:yourdomain.com';    .......

it is working ok now :nope:....but i am not receiving any email.....i have entered correct details for email address as per readme.txt......as per

@allow_mail_to     = qw(you@yourdomain.com localhost);

so please tell me what to do noww..... :hypno:

thanks for your kind suggestion....
Ked...
Title: Re: Setting up NMS FormMail
Post by: leighsww on December 26, 2006, 11:24:48 AM
Please provide a link to your form so I can test it out and help you better.
Title: Re: Setting up NMS FormMail
Post by: ked on December 26, 2006, 02:38:01 PM
Hi my link is as follows,

www.transvisioninfotech.com/addform.html

Now if you write anything in that and submit..it just goes to no thank.html that i didn;t upload...but anyway it should send the details to email in my file...so please let me know what i can do...  :help:...

cheers,
Ked
Title: Re: Setting up NMS FormMail
Post by: leighsww on December 26, 2006, 03:17:13 PM
ked -

I sent you a test email (it will have your own domain as the email addy). Let me know if you received it.

Check via webmail also, cuz sometimes if it's not coming to you via POP, it may be found waiting for you via webmail. If it's coming to you via webmail but not through your POP email client, then check to see if you have a filter or Spam Assassin setting which may be filtering them  :?

If you still didn't receive the submission email, then PM (Private Message) me your username and password and I'll see if I can find what the problem may be in your script or I'll test it via my email addy to see if I can receive the submission. You can change your password when I am done.

* Can a Moderator please move the posts starting from Ked's first post and all the ones thereafter pertaining to his/her issue to the "CGI" forum section. Best that this thread doesn't keep getting posted to if it's pertaining to a member's particular issue. THANKS!  :smiling:
Title: Re: Re: Setting up NMS FormMail
Post by: Lupine1647 on December 26, 2006, 03:38:34 PM
Done :)
Title: Re: Re: Setting up NMS FormMail
Post by: leighsww on December 26, 2006, 03:44:47 PM
Quote from: RyanJ
Done :)

Thanks, "Oh-wolfy-one-who-stalks-way-too-much" :)
Title: Re: Setting up NMS FormMail
Post by: ked on December 28, 2006, 02:50:47 PM
Hi,
how can i send you the private reply,

Please let me know thanks...
Ked
Title: Re: Re: Setting up NMS FormMail
Post by: Lupine1647 on December 28, 2006, 02:57:50 PM
ked,
You can send a PM by clicking on the IM bubble just under the poster's name.
Title: Re: Re: Setting up NMS FormMail
Post by: leighsww on December 28, 2006, 03:00:37 PM
Oh oh, I think he won't be able to until he has like 6 or 7 posts, as this forum has set a minimum post count for IM/PMs to work.

You might have to post a few more tiimes until you see the IM bubble, ked  :)

Just post "testing" in a few more posts, until you finally are able to IM/PM me, lol.

*edited -
Oh wait ... I wonder if I'm able to IM you, and then you can reply back once you see my IM? Let me try that.
Title: Re: Re: Setting up NMS FormMail
Post by: Lupine1647 on December 28, 2006, 03:01:28 PM
The min post count should be 5 so he just reached it :)
Title: Re: Re: Setting up NMS FormMail
Post by: leighsww on December 28, 2006, 03:02:56 PM
The min post count should be 5 so he just reached it :)

LOL, okie dokie then  :o :)
Title: Re: Setting up NMS FormMail
Post by: ked on December 29, 2006, 05:36:24 PM
Hi,
I changed my email to kedar@transvisioninfotech.com for just checking and wonder what...it suddenly started working...i don't know what was wrong with the other email...its great that problem was solved..

only problem now is i cant send you the private message....there is no bubble i can see....i have seen your private message came through to me in my notification email inbox...but cannot see it when i come to lunarforums... i just can't see it and it says you cannot view the personal message.....:shocked: .....
anyways i will try to send personal message...and hopes i will be able to....

i really thank u and hopes to send the pm after this message..so that u can check it urself for the above email id....
cheers..
Ked
Title: Re: Setting up NMS FormMail
Post by: BettyBop8171 on July 27, 2007, 12:38:05 PM
Got a questin on the "THE FormMail.pl SCRIPT:" and post by "leighsww" the afore mentioned tough love cuddly one.

Can you tell me if I hae this code correct, I'm trying to email form responces to BOTH of these addresses.

@allow_mail_to = qw(webmaster@nfp-rocks.com contact@nfp-rocks.com localhost);

Hope you can help.
-jay
Title: Re: Re: Setting up NMS FormMail
Post by: leighsww on July 27, 2007, 07:03:24 PM
Got a questin on the "THE FormMail.pl SCRIPT:" and post by "leighsww" the afore mentioned tough love cuddly one.

Can you tell me if I hae this code correct, I'm trying to email form responces to BOTH of these addresses.

@allow_mail_to = qw(webmaster@nfp-rocks.com contact@nfp-rocks.com localhost);

Hope you can help.
-jay

That won't work for sending to multiple email addys. Follow this post instead:

http://www.lunarforums.com/index.php?topic=28338.msg221777#msg221777
Title: Re: Setting up NMS FormMail
Post by: garymeek on April 29, 2009, 11:32:45 AM
I am at my wits end trying to set up NMS FormMail!  Can someone help?  I can post/link to my html page and NMS FormMail script:

Title: Re: Setting up NMS FormMail
Post by: Adloveadmin on May 13, 2009, 12:24:03 PM
Well...

I've followed the instructions at http://www.lunarforums.com/lunarpages_how_tos/setting_up_nms_formmail-t18221.0 and http://www.lunarforums.com/lunarpages_c_perl_cgi/formmailpl_bad_gateway-t33731.0.html;msg253395#msg253395 and just can't get the nms scripts formmail to work.  The "Shebang" line referenced in the posts doesn't exist in the .pl file.

Here is the pertinent info from the formail.pl file (renamed FM.pl).  Adlove.org is the site in question and it's on a Windows server.  Files were uploaded using ASCII transfer.
----------
#!C:/perl/bin/perl.exe
#
# NMS FormMail Version 3.14c1
#

...snip snip...

  $DEBUGGING         = 1;
  $emulate_matts_code= 0;
  $secure            = 1;
  $allow_empty_ref   = 1;
  $max_recipients    = 5;
  $mailprog          = 'SMTP:adlove.org';
  $postmaster        = '';
  @referers          = qw(adlove.org localhost);
  @allow_mail_to     = qw(webmaster@adlove.org localhost);
  @recipients        = ();
  %recipient_alias   = ();
  @valid_ENV         = qw(REMOTE_HOST REMOTE_ADDR REMOTE_USER HTTP_USER_AGENT);
  $locale            = '';
  $charset           = 'iso-8859-1';
  $date_fmt          = '%A, %B %d, %Y at %H:%M:%S';
  $style             = '/css/nms.css';
  $no_content        = 0;
  $double_spacing    = 1;
  $wrap_text         = 0;
  $wrap_style        = 1;
  $address_style     = 0;
  $send_confirmation_mail = 0;
  $confirmation_text = <<'END_OF_CONFIRMATION';
From: webmaster@adlove.org
Subject: form submission

Thank you for your form submission.

END_OF_CONFIRMATION
----------

The error generated when using a test form from the web site is...

----------
Content-Type: text/html; charset=iso-8859-1

<?xml version="1.0" encoding="iso-8859-1"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
 <head>
  <title>Error</title>
 </head>
 <body>
  <h1>Application Error</h1>
  <p>
   An error has occurred in the program
  </p>
  <p>
   connect to &#91;adlove.org:25&#93;: Unknown error at &#40;eval 8&#41; line 70.

  </p>
 </body>
</html>
----------

Anyone have any ideas?  I'm at my wits end.

Thank you.
Title: Re: Setting up NMS FormMail
Post by: ljonston on June 26, 2009, 11:34:38 AM
I am at my wits end trying to s(https://bodybuilderspro.info/customimages/65/1240197088/random.gif)et up NMS FormMail!  Can someone help?  I can post/link to my html page and NMS FormMail script:



should i even bother with this?  Seems like a lot of hassle to get this figured out.